Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've been running into a problem where most accounts can't search my SharePoint main site through the search bar at the top-right of my page. I have a document library that they need to be able to search in, and it never returns any results regardless regardless of what is searched.

This is a picture of the search bar I'm referring to.

After further testing, domain admins are able to search fine but the rest of the accounts in the domain are not. I assume this is a simple fix, but I have been searching everywhere and have not found a solution. Has anyone run into this?

Thank you!

EDIT: I just tested this on the SharePoint server's admin account, and that worked too.

share|improve this question
    
Is the crawl account a local account or domain account? –  Dylan Cristy Jan 10 '13 at 14:18
    
It says that the crawl account is NT AUTHORITY\NETWORK SERVICE. –  ben Jan 10 '13 at 15:18
    
Do you have some kind of special permissions on your site? –  Alex Choroshin Jan 10 '13 at 15:38
    
No, I don't. I just changed the crawl account to a normal domain account that has local admin rights on the server, and it's crawling properly but still only displaying search results to those few select users. Most of the permissions are pretty OOTB. –  ben Jan 10 '13 at 15:43
add comment

2 Answers

Have you added Search service account to the "Windows Authorazation Access Group?" You may follow this link to do that http://troygerber.wordpress.com/2011/01/07/only-get-search-results-when-logged-into-sharepoint-as-sharepoint-farm-account/

share|improve this answer
    
Yep, I just set my crawl account to a domain administrator, added it to the WAAG, and it still does not work. Crawls and everything properly, but results can't be displayed to the regular users. –  ben Jan 10 '13 at 16:48
add comment

Option #1 This may be a permissions issue. I would carefully review the permissions on that library as well as the permissions on your results.aspx page.

Option #2 It sounds like you may have an issue with your search results (results.aspx) page. More specifically, the web part where the search core results are displayed. To edit this page you can go to:

{{yoursearchcenterpath}}/Pages/results.aspx?DisplayMode=Design&ControlMode=Edit

I would open that web part and check your settings. Specifically ensure that your "Results Query Options" are along the lines of:

  • Query Language => Browser Locale
  • Cross-Web part query ID => User query
  • Remove Duplicate Results => Checked
  • Enable Search Term Stemming => Unchecked
  • Ignore Noise Words => Checked
  • Fixed Keyword Query =>
  • Append Text To Query =>

Those last two are left empty.

share|improve this answer
    
#1. The users are able to access all of those files without the search, though. The permissions are relatively wide open, and my account even has full control of the library. Though it cannot see any results in search. #2. It doesn't let me get to a regular results.aspx page, but I am able to navigate to sharepoint/_layouts/OSSSearchResults.aspx? . It also isn't letting me get to sharepoint/_layouts/…, it just says that an error occurred when I try to go there. –  ben Jan 10 '13 at 16:41
    
So it sounds like option 1 isn't the problem. When you do a scoped search within the library your results page (regardless if results are displaying or not) should be results.aspx. Is this not the case? –  MAllen22842 Jan 10 '13 at 18:17
    
Nope, that's not the case. I just did a search in a library called "Test" for the item "searchtest". It brought me this for the (empty) results page: sharepoint/_layouts/… –  ben Jan 10 '13 at 18:30
    
In MOSS 2007 this problem would occur when the default zone for the web application didn't match the same URL as the start address of the content source. Changing the zone via Alternate Access Mappings (AAM in Central Admin) by setting the start address as the default or changing the start address in the content source normally fixed the issue. What are your settings under Site Settings | Site Collection Administration | Search Settings? Any custom Search Scopes under Site Collection Administration | Search Scopes? –  MAllen22842 Jan 10 '13 at 19:47
    
Please remember to vote if this was helpful to you or not. Thanks. –  MAllen22842 Jan 16 '13 at 3:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.