Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I had been using SP2010 Beta for 7 months or so, and had the task lists set up such that when a task was assigned to someone, an email was sent to that person. I moved over to RTM, and am having trouble getting this to work. An email will be sent to the person assigned to the task when something in the task changes, but not when it is first created/assigned. Can someone help shed some light to this? I have smtp configured correctly, and the task list's advanced settings are set so that Email Notification is sent when ownership is assigned or when an item changes.

Please Advise.

Thanks, Josh

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

That is peculiar. Since you say you were on Beta but moved to RTM, I wonder if this content database restoration issue may be applicable in your situation: http://weblogs.asp.net/mellota/archive/2007/10/11/sharepoint-2007-task-notification-alert-emails-not-working.aspx

Another example that had a similar solution: http://www.itsallaboutsharepoint.co.uk/2009/11/06/task-lists-not-sending-email-alerts/

If by chance you recently changed the list permissions so that a user can see/edit all items or only their own items, then this may be a permission thing. (See http://www.sharepointdev.net/sharepoint--setup-upgrade-administration-operation/issue-with-task-list-assigned-to-column-not-sending-email-9090.shtml)

share|improve this answer
1  
The solution to this problem was restarting the box. But, the Answer above from Rob is useful. –  Anonymous Sep 27 '10 at 15:36
1  
Josh - What are the odds? The one time I didn't lead with rebooting the server... :-) Glad you figured it out! –  Rob Wilson Sep 27 '10 at 20:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.