Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have set up SharePoint 2010, created a web app + site collection, I'm using a domain account which is the site collection admin.

Everything appears "Peachy", until I get to the login prompt when accessing the site. The credentials simply don't work, and it keeps prompting for a login.

Any ideas why?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

For the record, this solved my issue on Windows Server 2008 R2 running SharePoint 2010.

ALSO AS DC! :) For all you purists!

Disable the loopback check loadTOCNode(2, 'workaround'); Follow these steps:

  1. Click Start, click Run, type regedit, and then click OK.
  2. In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  3. Right-click Lsa, point to New, and then click DWORD Value. Type DisableLoopbackCheck, and then press ENTER.
  4. Right-click DisableLoopbackCheck, and then click Modify. In the Value data box, type 1, and then click OK.1.2.

RESTART PC!

share|improve this answer
1  
I hope that's not a production box you've disabled loopbackcheck on, very bad practice. Here's the a reason why: harbar.net/archive/2009/07/02/… –  James Love Sep 17 '10 at 17:17
    
Nope, its development :) –  user879 Sep 17 '10 at 17:31
    
Good good, just checking ;) –  James Love Sep 17 '10 at 18:02
    
Excellent article, thanks James! –  user879 Sep 18 '10 at 12:32
add comment

One thing to check is to be sure you are domain qualifying your user name. Sometimes it will want to default to machine name.

I've also seen this happen before when the SharePoint service jobs were set up to run with a local system account. Are you able to browse the site from the server, just not from another workstation on the LAN? If so, try changing the service jobs to use the network service account.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.