Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am building a publishing site in SharePoint 2010, but I have get in troubles when I choose a masterpage: I have to choose the same masterpage to back-end pages and to site pages.

I know that I can choose a site master page (to the pages that the common users see) and another system master pages (to the back-end pages, the pages that the administrators and privileged users see). The problem that I have is when I choose a System master page, it is assigned to the back-end pages and also to the site pages. And when I choose a site master page, it has no effect.

Anyone has the same problem?

Thank you

share|improve this question

3 Answers 3

Well Pedro, while you are right that the master pages are used for different types of pages, you're a little off on which types of pages use which type of master page.

Publishing pages in your publishing site will use the site master page that you specify. These are the pages that are stored in the Pages library of your site by default. Publishing pages use predefined page layouts and typically have an approval workflow associated with them.

The system master page is used for all web part pages, forms, list views, wiki pages and administrative pages (among others I'm sure I haven't listed). Basically, everything but your publishing pages and error pages.

See Stefan Goßner's (brief) post about this: Site Master Page vs. System Master Page

share|improve this answer
    
rjcup3, I am completely agree with you. Maybe I haven't explained on the right way. The problem is that my publishing pages are using System master page. So, what could be the cause of this problem? –  Pedro Calero Jan 9 '13 at 14:51
up vote 0 down vote accepted

I have solved the problem. It was that all of the publishing pages of my site, in the head, they had: "~masterurl/default.master" And they should have "~masterurl/custom.master".

Thankyou @rjcup3 because your link was very helpful for me.

share|improve this answer

To hopefully add a bit more value to this thread, it should not be necessary to edit the page in SharePoint Designer to set the master custom.master to overcome your problem - if you do you will open up another can of worms whereby a banner is displayed at the top of each page you have modified which reminds users that "The current page has been customized from its template. Revert to template".

Here's the answer to be able to use the "Site Master Page" setting as it was intended: - Pages created in the SitePages library cannot take advantage of the "Site Master Page" setting in "Site Settings>Look and Feel>Master Page" and all pages will adopt the setting for the System Master Page. Only pages created in the "Pages Library" take advantage of the "Site Master Page" master page setting. By recreating your pages in the "Pages library"you can overcome all of these obstacles.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.