Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have just installed SharePoint Foundation 2010 on a Window Server 2008 R2 using choosing Standalone during installation.

On the Windows Server 2008 machine there are two administrator accounts. One created during Windows installation and one added later.

The problem is that these two accounts behave in different way.

I can access with both accounts to the SharePoint Central Administration -> Application Management section.

But with the one created during Windows Server 2008 installation I can see the buttons New, Extend and Delete when I click over an application name.

Instead with the other administrator account this buttons are grayed out.

I cannot find a solution to this situation. I would like that other administrators account have the same permission of the one that was created during W2K8 installation.

share|improve this question
add comment

4 Answers

The first account you mentioned, that has the access to the commands buttons, was it by chance the logged in account when you installed SharePoint? That could be the difference. When you install/configure SharePoint, it grants special permissions to the service accounts that you provide it.

Check out this article: http://technet.microsoft.com/en-us/library/ee662513.aspx and some of the others it links to. It explains some of the permissions that are set if you want to make the account permissions identical.

share|improve this answer
    
Yes, I installed SharePoint with that account, and then due to an error we delete it –  Drake Sep 17 '10 at 15:53
    
One thing you may want to try is to register a service account in Central Admin for the new account. Then assign that account as the Farm Admin. If that is already done, or if it does not work, is your site new enough that you can delete it and recreate it under the new account? –  Rob Wilson Sep 17 '10 at 17:15
    
I didn't like but at the end I did a complete reinstall, and now it works. –  Drake Sep 20 '10 at 9:47
add comment

If you are on your virtual machine remote desktop you must run IE as administrator.

share|improve this answer
add comment

I have replicated your issue, I am going to clarify the problem as I needed to read it several times to figure out what you were asking.

We are working in Central Administration (CA).

Problem: We want to add a domain account user to the "Farm administrators" group. The new account mydomain\mstest1 cannot use the "New", "Extend" or "Delete" buttons on the ribbon within "Web Application Management".

Replication: 1.> Add the new farm admin account to the farm admin group CA > Security > Manage the farm administration group. Add the new domain account.

2.> Add a new web application to the farm CA > Application Management > Manage Web Applications. New, Extend and Delete are greted out if you log in as the newly created domain account i.e. mydomain\mstest1

Rolling over the buttons on the ribbon display the following information: "This control is currently disabled." "You might not have the right permission level to use this, you might need ...".

Additionaly you will also notice the "Manage Service Applications" will not allow you to create or delete new Service Applications.

Resolution: As James Love mentioned, you need to add the new Central Administrator site collection admin to the SQL Server roles, you only need dbcreator and dbsecurity. You don't need the db_owner.

For more info: Fix the control is currently disable message

share|improve this answer
    
In fact I cannot add any user to Farm Administrators group. When I select one and press OK I receive the error: An unexpected error has occurred. –  Drake Sep 17 '10 at 15:50
add comment

Have you assigned that farm account to the appropriate roles in SQL Server? You'll need to assign the account to the dbcreator, db_owner and securityadmin roles.

share|improve this answer
    
In CA->Security->Farm Administrator is set to "BUILTIN\Administrator". Now I assigned to BUILTIN\Administrators the roles: dbcreator, securityadmin and sysadmin. I also set "BUILTIN\Administrator" user to db_owner for all databases relasted to SharePoint but I have still the problem to see New, Delete buttons. –  Drake Sep 17 '10 at 15:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.