Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a problem in SharePoint 2010. I can't open document library JPG (*.jpg) file in computer application, not in browser (IE). I tried to set "Strict" option in "Browser File Handling" (CA web application settings), but result was the same. Then i tried to set "Default open behavior for browser-enabled documents" for document library to option "Open in the client application" but still picture is opened in browser. I also tried to remove MIME type "image/jpeg" from "AllowedInlineDownloadedMimeTypes", but then SharePoint only suggest to save file to computer - there is no "Open" option.

Anybody know any other solution for this?

By the way when I click on picture link in document library, firstly it shows message "Some files can harm your computer. If the file information looks suspicious or you do not fully trust the source, do not open the file..." Then when I press "OK" button it opens picture in browser (IE).

Thanx

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I compared document library image link in old SP2007 with the new one after migration (in SP2010). And I figured out that links are different: in new SP environment links there is no attribute "target=_blank" hyperlink element. So the only one solution (workaround) for us left, is to write JavaScript code which could add necessary attribute for hyperlink on page load event. However, I think that it isn't the best solution. Because if we include that JS code to master page (because we want same link action in all environment) we will meet the lower performance issues.

Anyway, today it's the only solution for me.

share|improve this answer

You need to Set the default open behavior for browser-enabled documents in the document library using the following steps:

Assuming you have design permissions on the list, you should:

  1. Navigate to the site where you want to change the setting for the library.
  2. Click the name of the library on the Quick Launch, or click Site Actions , click View All Site Content, and then in the appropriate libraries section, click the name of the library.
  3. In the ribbon, under Library Tools, click the Library tab, and then in the Settings group, click Library Settings.
  4. On the List Settings page, under General Settings, click Advanced Settings.
  5. On the Document Library Advanced Settings page, in the Opening Documents in the Browser section, under Default open behavior for browser-enabled documents, do the following: To open a document with one click by using an application installed on your computer, click Open in the client application.

When this is done, you're jpg-file should open in the application!

share|improve this answer
    
Thanks for your answer but as i wrote (Then i tried to set "Default open behavior for browser-enabled documents" for document library...), i tried this, and the result was the same - jpg-file still opens in IE. –  Ricardas Mockus Jan 8 '13 at 15:01
    
@RicardasMockus Do you have a default application set for opening jpg-files on your client PC? Maybe it is set to be IE and not the application you want it to be? –  Benny Skogberg MCSA Jan 8 '13 at 15:11
    
Yes i thought about this too... And default application for JPG is set for "Windows Picture and Fax Viewer". –  Ricardas Mockus Jan 8 '13 at 15:18
    
@RicardesMockus What does your browser setting say on opening jpg-files? IE or W Picture Viewer? –  Benny Skogberg MCSA Jan 8 '13 at 17:55
    
Hi, i don't understand the last question. Do you mean, can i open jpg-files with browser directly? - if so, then yes i can. Sorry for misunderstanding :) –  Ricardas Mockus Jan 9 '13 at 7:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.