Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have some functionality that automatically creates sites.

What we are wondering is if the request goes to one of the servers to create the site, and then there is a request to read the site that goes to the other server. Is there a chance that the site is not available?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

No, a site and its contents are stored in a Content Database and your load balanced web front end servers operate on the same Content Database. Once it's in the database (when creation completes) it's ready to be served by any of the web front ends.

share|improve this answer

I've only seen this when creating new site collections, not subsites off an existing site collection. There are some instances, especially in sharepoint 2003, where the cache on the other servers wouldn't be expired correctly, and I would get a 404 when trying to access a newly created site collection on another wfe from which it was created. If you are running into that on SP 2007 make sure your farm is configured properly and the sptimer service is working correctly on all of your wfe's.

share|improve this answer
    
I don't see how the timer job has anything to do with the creation of a site collection. A site collection is just an "object" in the database - just like a subsite. Perhaps you mean the creation of a web applcation? That would make sense as an IIS site needs to be created on all WFE's by the timer service (it's more than just an object in the database), which may not happen at the same time for each WFE. Please correct me if I'm wrong. –  Jaap Vossers Nov 19 '09 at 21:59
    
Well, since the url topology changes with a site collection, it was my understanding that in sp 2007, a timer job gets kicked off and it runs on each wfe to update it's url topology cache. I know it's all stored in the db but you can't expect to get much performance if MS coded SP to check the database each time a site is sent to a browser for all the information needed to render that site. They cache a lot of the basic info such as managed paths and which urls contain SP sites. See technet.microsoft.com/en-us/library/cc424971.aspx for the timer job that does this. –  Steve Lineberry Nov 20 '09 at 13:20
    
Do you have more proof to backup your theory? That url doesn't cut it for me. It's quite vague about what cache exactly it refreshes, and neither does it say that it runs when someone creates a site collection. I'm not saying you are wrong, i'm just not convinced :) –  Jaap Vossers Nov 20 '09 at 15:07
    
You are right, a new site or site collection doesn't kick off a timer job. The config-refresh job actually runs every 15 seconds and since it takes longer than 15 seconds to create a site collection or subsite all of the wfe's receive their updates before when the site is requested in the browser. If I get some time, I'll do a test at work. I'll stop the sptimerv3 service on one of the wfe's and create a site or site collection on another wfe. Then i'll try to access the site I just created on the wfe with the timer service stopped. –  Steve Lineberry Nov 23 '09 at 20:29
    
It also seems some other people have noticed something similar: stackoverflow.com/questions/1087822/… –  Steve Lineberry Nov 23 '09 at 20:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.