Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have installed SharePoint Server 2013 on a Windows Server 2008 machine. In our development environment we have installed Visual Studio 2012 on a Windows 7 machine and have installed Office Development Tools to develop SharePoint 2013 web parts.

We are able to link to the site on the remote server, but after saying "Deploy solution" it's displaying this error:

Error occurred in deployment step 'Install app for SharePoint': Apps are disabled on this site.

Please help us with this problem.

share|improve this question
add comment

2 Answers

This link will help you

Install App for SharePoint

share|improve this answer
3  
While this may theoretically answer the question, we prefer a description of the solution here, and provide a link just for reference. Links alone are of limited use to users of the site particularly as they might change. –  SPDoctor Jan 3 '13 at 18:18
add comment

Before you can deploy a SharePoint hosted app to your SharePoint Preview development environment you have to configure an isolated app domain.

like this :

http://sharepointchick.com/archive/2012/07/29/setting-up-your-app-domain-for-sharepoint-2013.aspx

http://msdn.microsoft.com/en-us/library/fp179923%28v=office.15%29

Hops it helps!!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.