Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have been running into an issue on MOSS 2007 for the last two weeks, users are reporting extremely slow responses from SharePoint, a lot are reporting time outs when doing anything within Sharepoint. I have run through all the usual items and cant find anything that could be causing this, it is definitely not load as there are roughly 10 to 20 people using SharePoint currently in the Christmas period, which is at roughly 200 when everyone is in the office.

We have found some locks on the UserData table in the DB but clearing these when they happen only provides a marginal improvement. I have checked with both the server and network teams who have indicated that there is no updates/work happening on the servers/networks.

Has anyone have some ideas on other stuff to look at in or out of SharePoint that maybe causing this slow response and time out?

share|improve this question

2 Answers 2

a similar question has been asked and i dont want to recreate the wheel ;)

heres the link... just follow the steps to find out whats causing the problem!

Why is SharePoint so slow?

and

http://stackoverflow.com/questions/112318/sharepoint-2007-performance-issues

also just a side note, is it happening on any page or only on specific pages? If its on all then deffo look at the urls iv posted, if its on only specific pages than look at what are on those pages (custom webparts) that could be the cause by not disposing of the objects correctly or not using the using statment. Can also be a cashing issue.

my two cents are check sql is handling the request properly and check your network as its usually one of the two that make sharepoint slow.

Hope it helps!

share|improve this answer

agree with almostSharePointMaster theres certainly some information floating around about this but considering this is an issue that has been introduced within a time window then it might pay to investigate if anything else was introduced into the network around that time (2 weeks ago). Any changes to the proxy server arrangement, any updates applied to the SP server or DB server, whats your DB server running like (log files full for example), are you getting any useful feedback from the Event viewer and also from the ULS logs for SP2007. What antivirus software is deployed at the environment, for example I know that endpoint has a known compat issue with 2007.

hope you can get to the bottom of it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.