Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a site column Construction - Complete Date which is used by my calculated column Construction - Is Complete?. Whenever a date is entered for the Construction - Complete Date then Construction - Is Complete? should be equal to "Yes" otherwise it is "No".

My calculated column formula reads as below:

=IF(ISBLANK([Construction - Complete Date]),"No","Yes")  

However, when I save the calculated column and check my existing rows the calculation is not being done correctly. When I go back to my calculated column the formula has changed to this:

=IF(ISBLANK(#NAME?-#NAME?),"No","Yes")

I've read in this blog article that it is a problem for site columns but not for list columns and that the solution is to change the name and remove the "-". However, I need to keep it as a site column because it is used by multiple content types and I use the "-" convention to group common fields that are all for the same list entry. Is there an alternative option where I could keep the name and get the calculated column to work?

share|improve this question

1 Answer 1

The Construction - Complete Date is the Name of your column, but if you look closely, you'll find that SharePoint changes that '-' into a space. Hover over the column in the library/list settings under Column, and you'll find the internal name of the SharePoint column, and use that.

share|improve this answer
    
I tried change the "-" to a space (3 spaces total) but that didn't work ("Construction Complete Date"). I got the error "The formula refers to a column that does not exist." Also, when hovering over the column in the settings I didn't see the internal name. –  skeletank Dec 31 '12 at 17:00
    
Try with another space between Construction and Complete. Remember it's "Construction - Complete Date" so removing the "-" out and replacing it with a space makes it "Construction---Complete Date" (three spaces between Construction and Complete. –  Mike Dec 31 '12 at 17:10
    
That's what I did. In my comment I entered 3 spaces but SharePoint Overflow reduced it to 1. –  skeletank Dec 31 '12 at 18:12
    
Well try hovering over the column link in the list settings and it will show a URL with the Internal Column name in its parameters. Use that and consider %20 is a space –  Mike Jan 1 '13 at 18:32
    
I tried using the internal name (which includes '_x0020' and other weird characters) but it did not recognize it. BTW, I need to change this at the content type level and not at the list level so the internal name at the list settings level might not be the same. –  skeletank Jan 2 '13 at 14:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.