Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I got the following error when i go to the home page, site setting pages etc in my Sharepoint Site...

**Server Error in '/' Application.

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.] Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties() +134 Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_PartitionIDs() +44 Microsoft.Office.Server.Administration.UserProfileApplicationProxy.IsAvailable(SPServiceContext serviceContext) +329 Microsoft.Office.Server.WebControls.MyLinksRibbon.get_PortalAvailable() +44 Microsoft.Office.Server.WebControls.MyLinksRibbon.EnsureMySiteUrls() +60 Microsoft.Office.Server.WebControls.MyLinksRibbon.get_PortalMySiteUrlAvailable() +15 Microsoft.Office.Server.WebControls.MyLinksRibbon.OnLoad(EventArgs e) +91 System.Web.UI.Control.LoadRecursive() +65 System.Web.UI.Control.LoadRecursive() +190 System.Web.UI.Control.LoadRecursive() +190 System.Web.UI.Control.LoadRecursive() +190 System.Web.UI.Control.LoadRecursive() +190 System.Web.UI.Control.LoadRecursive() +190 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2427

Version Information: Microsoft .NET Framework Version:2.0.50727.4016; ASP.NET Version:2.0.50727.4016**

Thanks in advance. SR

share|improve this question
    
Did you try to perform an IISReset on the server running the user profile service application and if needed restart this service? –  Seb Dec 27 '12 at 8:10
    
i tried that. but it's not work. –  SRanj Dec 27 '12 at 8:23
    
I think there is some error on your page. pls open another page –  Hitesh Chandegara Dec 27 '12 at 9:47
    
I have 10 local site's in sharepoint. In all of the sharepoint Site's, when i navigate to Site Actions -> Site Settings-> then click anyone in Galleries i got this error.. This error occured in my Central administration site also. –  SRanj Dec 27 '12 at 10:53
    
any recent customizations I would try to roll-back...Including features/css/masterpages –  Mike Dec 27 '12 at 18:13
show 1 more comment

2 Answers 2

I sloved the issue by:-

  1. Stopped the User profile sync service
  2. Stopped user profile service application
  3. Recycled SecurityTokenServiceAppPool with re-typing credentials
  4. Started User Profile service
  5. Started Sync service

For more information Please see the below url:
http://social.msdn.microsoft.com/forums/en-AU/sharepointgeneralprevious/thread/f06b5803-1c71-4203-b46a-1c22ee646b59

share|improve this answer
    
this trick doesnt work to me :( –  user14312 Jan 22 '13 at 14:58
add comment

Perform an iisreset on your system.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.