Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Add New Item Link not appear in Sharepoint List.

I logging with admin account(having full control).

enter image description here

How to resolve ?

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

check this out:

1. Go to the list that is lacking the link

2. Select the view that doesn’t have the link appearing

3. Select Edit Page from the Site Action menu

4. Edit the list web part properties

5. Note the current Toolbar setting

6. Change the Toolbar setting and click Apply. Any selection other than No Toolbar should cause the link to appear after you click Apply.

7. Reset the Toolbar setting to that noted in 5 and click Apply again. The link should be appearing correctly.

8. If you need to do this for additional views on the list select the view from the Selected View pull down menu and repeat steps 5 to 7 for each view.

9. When complete click the OK button and then click the Stop Editing button in the page ribbon.

taken from:

http://kirkbarrett.wordpress.com/2012/05/02/add-new-item-link-not-appearing/

share|improve this answer
    
It is a bit faster to get to the right screen by using the drop down arrow on the list. My issue is with that of a Custom List. The Show Toolbar choices only show the + sign with no text like "add new item". I am assuming the text must be configured for Custom Lists, so will keep looking. –  Ricahrd Jenny Feb 12 at 20:03
    
@RicahrdJenny you first need to see if there is any css applied to your page that could be effecting the visual outlook as i presume you have the add item but it only displays the plus sign? goto f12 developer tools in ie and inspect the "+" element to see if there is any custom css that is efecting it! –  ali Sharepoint Feb 13 at 8:35
add comment

1)Select Edit Page from the Site Action menu

2) Edit the list web part properties

3)settings window opens and change the Toolbar type to "Full Toolbar" which can be seen in the dropdown. click ok and click stop editing on the top of the page . you can see "add new item" link button.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.