Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have downloaded SPTools from github, and have followed the directions of uploading the files to a Document Library. When I try to open the index.html file from the document library, I get prompted to save the file. If I open the file from my desktop, and run one of the operations (batch update list items), nothing happens. If I open the developers console (IE9), I can see the message "LOG: There are no source list items that match the specified CAML Query, Web URL, and List Name."

the CAML query I'm running is the default that comes with SPTools

<Query><Where><Neq><FieldRef Name="ID" /><Value Type="Integer">0</Value></Neq></Where></Query>
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

SPTools only work when the HTML files loads in the browser directly from the library.

As you're being asked to save it instead, this is a symptom of a security settings in SharePoint (to prevent potentially nasty code being ran). This security setting is called Browser File Handling, and you essentially need to set this to Permissive in your Web Application in Central Administration.

Once you do this, the HTML files will open directly in the browser and should work fine.

share|improve this answer
    
In case if you don't have access to the Central Admin and just want a "quick fix", just rename the extention of the file from .html to .aspx and it should work. Wrote a blog post on the subject a while ago: vrdmn.blogspot.in/2012/06/… –  Vardhaman Deshpande Dec 22 '12 at 20:42
    
Your suggestion worked! I knew I was missing something simple. I have also tried renaming the files extension, which worked as well. –  Jason Dec 22 '12 at 21:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.