Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a list on a subsite that I need to feature on the parent site homepage. I created the formatted data view and saved it as a web part in the gallery. I drop it on the homepage but get a "web part cannot be displayed, troubleshoot in designer" error message.

Then I created an unformatted data view and saved it to the gallery. I was able to get it to appear on the parent site homepage, but when I tried to apply conditional formatting - the columns for the "apply formatting" window don't appear - As in "Column" . It's all blank.

Am I missing something? It's just a simple dashboard with three traffic light indicators.

share|improve this question
add comment

1 Answer 1

If this is what I think it is, you need to export the web part to its Xml format (either .dwp or .webpart) and then edit it to fill in the WebID with the ID of the web that contains the list itself. Once that is done, you should be able to upload that as a webpart on any page in the site collection and it would work as expected.

You might also have to do something with the list ID or list url in the Xml, but I'm not certain on that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.