Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm setting up incoming email for SharePoint 2010 integrated with Exchange 2010 but I'm not sure what to do next to get it working.

The server is named sharepoint.domainname.local so when I installed the SMTP virtual server it was also created with this name. Next I created an SMTP alias named sp.websitename.com so that incoming email can be setup in SharePoint to go to list@sp.websitename.com. My company email format user@websitename.com.

Next I created a send connector in Exchange 2010 that is pointing to sp.websitename.com and specified the IP address the SMTP virtual server is installed on. I also setup AD DS integration that I have tested and appears to be working correctly.

What I'm not sure about is what to do next? I'm assuming I need to create an external mx record? Then incoming email will get routed to exchange which then sends it to the virtual smtp on the SharePoint server? How exactly do I set the MX record up? Thanks.

share|improve this question
    
Did you ever get this working? –  Steve Lineberry Feb 14 '13 at 20:15
add comment

1 Answer

You will need to go to the company's website which hosts your external DNS for websitename.com. Whoever bought the DNS name should have some login credentials to access their online tools. One of them should allow you to create that MX record.

share|improve this answer
1  
Update - I created an A record and MX record on my internal DNS server and incoming email IS working internally. When I send and email from an outside email address I get the email returned with a "message cant be delivered - nonexistent domain". So this means I still need to update the external MX record at the domain registrar? –  Paramount Dec 21 '12 at 18:23
1  
Yes, that is correct. –  Steve Lineberry Dec 21 '12 at 18:45
1  
Yes, you'll need to create an external record that points to your exchange server. If you have a firewall, you will probably need to point it to your firewall and then configure your firewall to send that on to your exchange server. –  Steve Lineberry Dec 21 '12 at 21:22
1  
I already have an MX record setup for the exchange server at mydomain.com and it's working fine because regular email comes in ok. But your comment about the firewall makes sense. I'm thinking the firewall needs to have an entry for emails ending in sp.mydomain.com. I will check on this. Thanks! –  Paramount Dec 21 '12 at 22:20
1  
Did you get it figured out? –  Steve Lineberry Jan 8 '13 at 2:25
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.