Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm running into somewhat of an odd issue. All of my site collections have been created as Blank Sites, and I've enabled features as required. One of the features that's been enabled on every site is the Publishing Infrastructure (at the site collection level) and the Server Publishing (at the site level).

One of our clients has been looking over the site, and is unable to see the changes; they just get 404 NOT FOUND pages. I figured out the problem, and turns out we had to check in/publish all our pages, and that resolved the issue. The weird part is that this user has been added to the Owners group for the site collection; they should be able to see and change everything.

For some further testing, I created a temporary username, and gave it the Approve and Design permissions. It couldn't see any of the draft pages, or changes made to checked out files. As part of the methodical testing, I gave it all the permissions of my site collection administrator (by using the Check Permissions under Site Permissions). The temporary user still can't see the changes, or unpublished pages.

My understanding of the workflow approval process is that Approve permissions are needed to see draft copies. This user has the same permissions as site collection administrator, but can't see any of the checked out changes.

What am I missing? Have I set up something wrong that should be applying the permissions? Or is SharePoint doing strange things?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

This may be an obvious answer, but it could be that you need to specify the approval users under the Versioning settings.

  1. Under General Settings of the list/library, click Versioning settings.
  2. In the Draft Item Security section, under Who should see draft items in this list or under Who should see draft items in this document library, click the group of users whom you want to enable to view drafts. The option for users who can approve items is available only if your library requires content approval.

  3. Click OK.

Source (also applicable for SharePoint 2010): http://office.microsoft.com/en-us/sharepoint-server-help/specify-who-can-view-drafts-HA010098643.aspx

Also, is there any customizations to SharePoint, such as javascript, css, features/solutions or custom masterpages?

EDIT: After a discussion, those users that are drafters, will have exclusive rights to the files and content they have checked out. No one else is allowed to see those drafts (even administrators) until the approval process is initiated through approval workflows, or otherwise checkedin for approval. Once the drafts have been checkin and submitted for approval, that's when it can be available for viewing.

share|improve this answer
    
Already checked the Pages and SitePages document libraries; both of their versioning settings are set to Off. Also, this thing is customized six ways from Sunday; JS, CSS, multiple custom solutions, features, and every site collection has a custom masterpage, too. –  fbueckert Dec 19 '12 at 22:46
    
Whoops, my bad. I misread the content approval setting as versioning. Content approval is off, and versioning is major + minor. Draft Item security is "Only users who can edit items." Either way, Owner permissions should allow me to see unpublished pages, no? –  fbueckert Dec 20 '12 at 15:21
    
If the owners have contributor to full control permission to that list, then yes, otherwise you need to be a site collection administrator. Make sure the list isn't uninherited. –  Mike Dec 20 '12 at 15:33
    
My document libraries are inheriting permissions correctly; double-checked that, too. So, my temporary username has the exact same permissions as my collection administrator, but still can't see unpublished pages. Strange. Very strange. –  fbueckert Dec 20 '12 at 15:40
    
I'd also make sure your masterpages and layouts are checkedin and published. –  Mike Dec 20 '12 at 15:46
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.