Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I believe this issue is unique to non-domain environments

I am trying to install SPF 2013 RTM in the following environment:

  • Windows Server 2012 RTM
  • Stand-alone installation using SQL Server Standard
  • Non-domain hyper-V instance (i.e. it is a workgroup)
  • TFS Server (stand-alone installation)

Installation steps taken:

  1. Install software prerequisites. OK
  2. Install SharePoint Foundation bits. OK
  3. Run New-SPConfigrationDatabase. OK
  4. Run SharePoint 2013 Products Configuration Wizard. OK
  5. After step 4 is completed, I am taken to the Central Administration Web site. I enter my credentials. I am presented with the following message "Sorry, this site hasn't been shared with you"

    Page requested:

    h ttp://tfs01:1841/_admin/adminconfigintro.aspx?scenarioid=adminconfig&welcomestringid=farmconfigurationwizard_welcome

    Redirected to the following page:

    h ttp://tfs01:1841/_layouts/15/AccessDenied.aspx?Source=http%3A%2F%tfs01%3A1841%2F%5Fadmin%2Fadminconfigintro%2Easpx%3Fscenarioid%3Dadminconfig%26welcomestringid%3Dfarmconfigurationwizard%5Fwelcome

Looking at the SP ULS logs, I see the following exception:

Unexpected Exception in SPDistributedCachePointerWrapper::InitializeDataCacheFactory for usage 'DistributedViewStateCache' - Exception 'Microsoft.ApplicationServer.Caching.DataCacheException: ErrorCode:SubStatus:There is a temporary failure. Please retry later. (One or more specified cache servers are unavailable, which could be caused by busy network or servers. For on-premises cache clusters, also verify the following conditions. Ensure that security permission has been granted for this client account, and check that the AppFabric Caching Service is allowed through the firewall on all cache hosts. Also the MaxBufferSize on the server must be greater than or equal to the serialized object size sent from the client.) ---> System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://tfs01:22233/. The connection attempt lasted for a time span of 00:00:00. TCP error code 10061: No connection could be made because the target machine actively refused it [2001:0:9d38:953c:c01:1617:f523:f0f0]:22233. ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it [2001:0:9d38:953c:c01:1617:f523:f0f0]:22233 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)

at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout) -
-- End of inner exception stack trace --- Server stack trace:

at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout) at System.ServiceModel.Channels.BufferedConnectionInitiator.Connect(Uri uri, TimeSpan timeout) at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout) at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout) at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

at Microsoft.ApplicationServer.Caching.CacheResolverChannel.Open(TimeSpan timeout) at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs) at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink) Exception rethrown at [0]:

at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase) at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData) at Microsoft.ApplicationServer.Caching.CacheResolverChannel.OpenDelegate.EndInvoke(IAsyncResult result) at Microsoft.ApplicationServer.Caching.ChannelContainer.Opened(IAsyncResult ar) -
-- End of inner exception stack trace ---

at Microsoft.ApplicationServer.Caching.DataCache.ThrowException(ResponseBody respBody, RequestBody reqBody) at Microsoft.ApplicationServer.Caching.DataCacheFactory.GetCacheProperties(RequestBody request, IClientChannel channel) at Microsoft.ApplicationServer.Caching.DataCacheFactory.GetCache(String cacheName) at Microsoft.SharePoint.DistributedCaching.SPDistributedCachePointerWrapper.InitializeDataCacheFactory()'.

An interesting point:

  • I am able to access central administration (h ttp://tfs01:1841/default.aspx) using the same credentials I used above. When I go to the Configuration Wizards, there is nothing I can do there. The account logged in shows as System Account.

    enter image description here

share|improve this question
1  
I heavily advice you against these kind of standalone, domain less installation (it's now the embedded database usage the issue, it's the lack of domain). Trust me, you'll run into all kind of trouble. It used to work quite OK in 2007 / 2010 but even with the RTM, some stuff are broken when you're installing on a non-domain environment. –  Francois Verbeeck Jan 1 '13 at 14:26
    
I agree with you. I have to eventually convince our IT Admin to migrate this server to a domain. Or, convince him to create a separate sever as a domain controller. –  Hossein Aarabi Jan 2 '13 at 8:12
    
Are you able to get this issue fixed? Thanks Sandy –  Sandy Jun 15 at 3:40
    
Yes, please see my answer below (solution #1) –  Hossein Aarabi Jun 16 at 18:28

3 Answers 3

up vote 5 down vote accepted

Solution #1 (preferred)

  1. Right click the SharePoint 2013 Central Administration > Run as administrator

    enter image description here

Solution #2 ( I do not think this solution works!!!!)

(Thanks to this blog post)

  1. Copy the Central Administration URL. Ex: h ttp://tfs01:47345/
  2. Go to Internet Options
  3. Select Security tab
  4. Select Local intranet
  5. Select Sites
  6. Paste the URL in step 1 (if complains that the site has already been added to trusted sites, select OK) . Select OK. Close. OK.

    enter image description here

    enter image description here

share|improve this answer

The solution is, to use the local admin-account for central Administration

LOCALHOST\Administrator

share|improve this answer

when you working with central administrator you should use only IE as a browser also IE should be run as administrator, even if your SP Site set as a local site. right click on IE -> run as admin will solve the issue

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.