SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to browse sharepoint site on dev site on the google crome but getting this below error. The site works fine with IE

enter image description here

Update the image : Right Click on Chrome shortcut >> Properties >> Then Append --explicitly-allowed-ports=77 to shortcut target - I am getting the below error

enter image description here

share|improve this question
I have the same error and below solution is not working for me. I can open my central admin in chrome but not web application. – raky Dec 17 '12 at 22:26
up vote 3 down vote accepted

I believe the issue here is that Chrome does not, by default, allow traffic through all ports. Notice in the screenshot that it's returning Error 312 (UNSAFE_PORT)... it would seem that port 77 is an unsafe port.


Right Click on Chrome shortcut >> Properties >> Then Append --explicitly-allowed-ports=xxx to shortcut target

share|improve this answer
Hi Ted, I tried it but i am getting an error - i have updated the question with the error screen shot – spStacker Dec 18 '12 at 0:17
Hm... make sure you specified --explicitly-allowed-ports=xxx in the shortcut and not just explicitly-allowed-ports - the '--' is important. – Ted N. Dec 18 '12 at 14:15
Hi Ted, i have used the --explicitly-allowed-ports=xxx, but still having no luck - i have updated the screenshot – spStacker Dec 18 '12 at 17:38
Ah, just tried this out myself...if you have any quotes within your Target box (""), remove them and try again. That fixed it for me. – Ted N. Dec 18 '12 at 17:42
Hi Ted .. Thanks for the solution worked "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --explicitly-allowed-ports=77 – spStacker Dec 18 '12 at 18:10

Chrome does not pass credentials by default like IE does so this would actually be normal and expected behavior if: 1) the site allows anonymous access and 2) the site uses a master page, page layout or page other server-side referenced file that has no published version.

The solution is to make sure that everything that goes into rendering the desired page is checked in and published. This also includes any javascript or images that might be referenced on the server-side.

share|improve this answer

This worked perfectly after a few attempts.

To be clear, you paste --explicitly-allowed-ports=xxx after the quotation marks in the target e.g.:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --explicitly-allowed-ports=79

I could then access the local site on the port I specified and it got round the ERR_UNSAFE_PORT issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.