Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

In a Sharepoint 2010 site I have a Discussion Boards list.

Now, each discussion board may have different participants, and I don't want to create a discussion board list per combination of participants, with only 1 item in the list.

How do I set up alerts that are specific for each discussion board, and not for the whole list?

Thanks!

share|improve this question
    
Will this be helpful: How to create SharePoint alerts for Discussion Board list items programmatically... This is for 2007 but will work for 2010 I guess! –  Arsalan Adam Khatri Dec 17 '12 at 15:26
    
How often will new discussion boards be generated? You can have users set alerts for the discussion board items they want alerts for... –  Mike Dec 17 '12 at 16:25
    
@Mike - so, a user can set an alert to an item in the list, but I, as the creator of the list, cannot create alerts for users for individual item, but just for the whole list? –  Amarundo Dec 17 '12 at 16:37
    
You can set alerts in behalf of other users as the administrator for list and inidividual items. Just set up an alert like you are setting it up for yourself...Use the drop-down menu to select "Alert Me", delete your name and enter in someone else's. If the username textbox is greyed out, you don't have the proper permissions. I think you need to have the "Manage Permission" rights of the site which is included in the Manage Hierachy and Full Control permission levels. –  Mike Dec 17 '12 at 18:52
    
@Mike - you didn't post this as an answer... How do I give it to you? –  Amarundo Dec 17 '12 at 19:03
show 3 more comments

1 Answer

up vote 0 down vote accepted

You can set alerts in behalf of other users as the administrator for list and inidividual items. Just set up an alert like you are setting it up for yourself...Use the drop-down menu to select "Alert Me", delete your name and enter in someone else's. If the username textbox is greyed out, you don't have the proper permissions. I think you need to have the "Manage Permission" rights of the site which is included in the Manage Hierachy and Full Control permission levels.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.