Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to configure Site Mailboxes and eDiscovery between SharePoint 2013 and Exchange 2013. The guidance on both of these is pretty much the same, create a server to server trust, then grant permissions to the AppPrincipal.

Here are the instructions for eDiscovery for SharePoint and Exchange:

http://technet.microsoft.com/en-us/library/jj655399.aspx

All the various pre-reqs seem to be met (UPS sync and MySites configured, Work Management and App Management service apps provisioned, etc). I am using SSL everywhere with certs issues from AD Cert Services, etc.

The problem I am getting is that when I create my SPTrustedSecurityTokenIssuer and then examine the registration, the .NameID property is blank. Unfortunately, the remaining instructions for granting permissions to AppPrincipcal require this property, and I am not sure why mine is blank.

enter image description here

Anyone have any idea why this property is blank, and how I might fix this?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

TechNet documentation is wrong. Do not use -IsTrustBroker parameter when creating trusted token issuer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.