Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

How do I set the ribbon to default Browse mode instead of default to Edit mode?

It is annoying to see the item details in view mode all the time and then click Browse to remove it...

share|improve this question
    
Could you perhaps provide a screen shot so that we can see exactly what screen you are looking at? I'm a site owner and all my pages default to Browse mode (unless you are talking about a different page type). I wonder if this is a function of your role. For example, are you set up as a designer for this site, or visitor or member? –  Rob Wilson Sep 10 '10 at 18:34
    
I'm facing the same problem. Did you ever find a solution? –  Jon Nov 5 '11 at 13:57
add comment

2 Answers 2

Take a look at the solution here. At the end of the function, there is this line:

_ribbonStartInit("Ribbon.Browse", true)

That will set that tab as default. You can change it to whatever you like.

share|improve this answer
add comment

Infact, I was also actually facing the same issue. So, I dig up the source of the page and found the interesting stuff in init.js (Sharepoint provided script file) script.

There is a parameter called InitialTabId set to different default values according to different pages.

Thats why you see different modes on different pages where on one page either browse tab is enable while on other edit or page tab is enabled.

One needs to set this parameter's (InitialTabId) value according to one's need.

For example, if you want to set Page tab as default value, set InitialTabId = Ribbon.WebPartPage

If you want to know what are the ID’s of the default tabs that comes with SharePoint, Take a look at “14\TEMPLATE\GLOBAL\XML\CMDUI.xml” in your “14 Hive”.

Inorder to have browse tab as your default tab, Set InitialTabId = Ribbon.Read in your QueryString

NJoy--

share|improve this answer
    
While this post may answer the question, we prefer more details such as "why". Please edit your post with additional details. See answer for general guidelines. –  SPDoctor Jun 1 '12 at 10:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.