Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Im having problems with scrolling in sharepoint site. I am fairly new to Sharepoint and have taken over the UX responsibilities for a site. The problem that Im having is that the scrollbar does not reach the bottom of the Site Settings > Site Navigation page. Users are forced to tab down to the bottom and when a user reaches the bottom of the page, the scrolling does no longer reaches the top of the page.

share|improve this question
    
is this a public site you could share the URL to for us to look at? –  David Lozzi Dec 13 '12 at 15:52
    
Does this page have any custom layout and or css on it? –  Hugh Wood Dec 13 '12 at 16:36
add comment

3 Answers

I've noticed problems before when using Google Chrome with SP2010. The scroll bars would only show up sporatically. Oftentimes it could be "fixed" by just refreshing the page.

Does this sound like what you're seeing as well?

share|improve this answer
    
No that doesn't seem to be the right fix. Myself and my users are predominantly in an IE8 environment and strangely enough this is only hapenning on one page. –  user13603 Dec 13 '12 at 16:22
add comment

It sounds like a CSS/HTML bug. If it's only showing on that one page, it could be a CSS margin issue. Without a screenshot and/or snippets of the applicable CSS/HTML it'd be pretty difficult for anyone to assist you.

share|improve this answer
add comment

The SharePoint 2010 is build in a "special" way, so the entire design (CSS/HTML) and javascript is dependent on each other for everything to work fluently.

I'm assuming you are using a custom masterpage, since this problem hardly ever occurs when using the default v4.master.

The structure of your masterpage after the ribbon should always contain the following DIVs:

  • s4-workspace (class)
  • s4-bodycontainer (class)
  • MSO_ContentDiv (id) (important that this DIV has runat=server for Toolpane to display properly in editmode)
  • MSO_ContentTable (id) with s4-ca (class).

Have these mentioned DIVs containing each other in that order and scroll should go from top to bottom.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.