SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We use Moss 2007. We have documents in a page where we can create documents on the server. While creating new document, after Microsoft word gets opened, a pop up is showing up for all users

The macros in this project are disabled. please refer to the online help or documentation of the host application to determine how to enable macros.

How to enable the Macros so the popup doesn't show up?.

Also when trying to save the following popup shows up

The file cannot be saved because some properties are missing or invalid use the Document information panel to provide the correct property values. Errors for required properties are marked with a red asterisk, and errors for invalid properties are marked with a red dashed border.

When filling the information panel like approver name and click on Find it says

This action cannot be performed for untrusted sites. To use Find you must add this site to the list of trusted sites for your web browser

But, the site is already added to the trusted sites in the browser

Again after filling the document information panel while trying to save on the server, shows pop up

This file has missing or invalid properties that are not displayed in the current document information panel view. To locate the missing or invalid properties, click the arrow next to properties in the document information panel and select a different view

Any suggestion on where can I disable the Macros popup and how to know the missing or invalid properties of the word document?

share|improve this question
Can you try to reset your security zones and try again? – Mike Dec 13 '12 at 16:48
where can I reset the security zones? – user9432 Dec 14 '12 at 6:11
(IE Menu Bar) Tools -> Options -> Security Tab -> Reset all zones to default level. – Mike Dec 14 '12 at 14:31
Its the same even after Reset – user9432 Dec 17 '12 at 3:49
Is your sharepoint site in the trusted list of sites in IE? – Mike Dec 17 '12 at 15:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.