Sign up ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Running SharePoint 2010. I have a library that has a folder for each user. Each user has contribute rights to their own folder. However, for some users, even if I give them Full Control, they never see the "+ Add Document" link. I assigned the rights exactly the same way for every user, so not sure why a few users aren't seeing it. Any ideas on how to go about troubleshooting this?

Thanks in advance.

share|improve this question
Got the same situation, Add Document is only available to the user who can access the entire document library, currently user has to use ribbon toolbar on the top to upload document. –  Shawn Dec 13 '12 at 1:37

5 Answers 5

  • Go to Library Permissions.
  • Stop Inheriting Permissions.
  • Remove All Permissions.
  • Grant permission to your Group which has Contribute Permission.

Also, check the Toolbar Type of the Library Webpart. Ensure that it is 'Full Toolbar'.

share|improve this answer

If you find that permissions are not the issue, I found a way to add it back in:

  1. Go to the library
  2. Click "Site Actions" in the top left and then "Edit Page"
  3. In the library webpart, click the drop down and select "Edit Web Part"
  4. Check "Toolbar Type" in "List Views"
  5. If "No Toolbar" is selected, change it to "Full Toolbar"
  6. If "Full Toolbar" is already selected, choose "No Toolbar" click "OK" and then switch it back to "Full Toolbar" (I had to do this)
  7. Click "Ok" and then in the ribbon click "Stop Editing" to save the page

I reversed the instructions from this page: Hope that helps.

share|improve this answer
How to do this process programmatically in sharepoint online sandbox solution ? –  Ronak Patel Feb 18 at 12:38
I'm not sure. I only know how to do it using the user end of SharePoint. –  Nicole Feb 25 at 18:42

If you granted specific permissions for the folders in the Document library, "+Add Document" link can not be used. You should use the link on the ribbon.

share|improve this answer

If it is possible in your case, try to set read permissions for the users for the whole document library.

In my case, I resolved it by additionally giving the users read permissions for the whole document library, besides the already given contribute permission for the folder.

I can not say, if it is a bug or a feature, because I resolved it by trial and error, but for my users it works. They can now see the +add document button.

share|improve this answer
I'm seeing the same issue in SP 2013. User in group. Group has Read on library and Contribute on subfolder. Add Document button doesn't appear when browsing subfolder. But Ribbon > Upload Document is enabled. –  robaker Oct 30 '14 at 12:11

Every user who should see the + Add Document link are the users who have at least contribute access to that particular list. Please verify that all your users who should have the add link have that permission.

Here's a walk through trough:

(1) Access the list all items by clicking the header link. Your URL should end with <list name>/AllItems.aspx if you done it right.

(2) On the List Tool > List ribbon, find the List Permission icon and click on it. List permission button

(3) In the new view (Permission tools), click the Check Permission button. Check permission button

(4) In the modal dialog, enter your failing user and check hers permission. Check permission dialog

If you find that your user have less permission than Contribute, add the user to the group with contribute access. More to read: User permissions and permission levels (SharePoint Server 2010)

share|improve this answer
Thanks for the quick reply. When I check the AllItems section, my user only has Limited Access, which is to be expected. When I check her folder (the one she should have access to), she has Contribute access. Still no "+ Add Document" link. Again, if I give her Full Control to that folder, she still doesn't see it. –  Howard Yuan Dec 13 '12 at 19:34
@HowardYuan Oh It was a folder. That's trickier, but there is a guide for that too: Permissions for a Document Library folder in SharePoint –  Benny Skogberg Dec 13 '12 at 19:58
@BennySkogberg: When I give Contribute permissions to the user on the designated folder, the "Add Documents" link is still not showing. Is there a way to fix this? –  TempaC May 30 '13 at 8:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.