Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a SPD 2010 workflow that is starting an approval process and assigning a task to a user. I'm running into an odd issue. When a user with contribute permissions on the Task list tries to view an assigned task, she is getting "An unexpected error has occurred." When I check the logs, this is the actual error:

"System.ArgumentNullException: Value cannot be null. Parameter name: item"

However, when someone with full control on the list tries to view the task, no problem.

Things I've tried:

-I've made sure that in the list settings users are able to read all items and create/edit all items, not just items they've created. -I've also tried giving the user Manage Lists permission, because it says in the list settings: "Note: Users with the Manage Lists permission can read and edit all items." This seems to have no effect.

This seems to point to a permissions problem to me, though it doesn't really make sense, and that error message seems odd as well. Anyone have any other ideas I can try?

share|improve this question
add comment

1 Answer

Try wrapping your workflow logic in a special "Impersonation Step".

There's a button in SPD for doing this. When you use this device, SPD will save the workflow using your current login credentials and it will "run as" such.

Eventually, you'll want your network admin to set up a service account for this so that when you move to a different company (or, more likely, you change your password in a few days) it won't break the workflow.

Once the service account is setup, re-login to your PC using that account.. open up the workflow in SPD, and re-save it so the service account credentials are used instead.

share|improve this answer
    
I gave this a shot, but it didn't work. My workflow runs just fine, no issues with it executing, it's just the tasks list that is giving me grief. Thanks for the idea. –  gsmith140 Dec 11 '12 at 18:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.