Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a tenant on SharePoint Online (the new 2013 version). In that tenant, I have a Project Online site collection. Project Online hosts a very nice OData endpoint at http://sampletenant.sharepoint.com/sites/pwa/_api/ProjectData. I can connect to this OData endpoint via Excel with no problems at all, and pull in whatever tables I would like to view.

On a SharePoint site in my tenant, I would like to create an External Content Type, instantiated as a SharePoint list, connected to one of the tables on the SharePoint list. I am following the steps in the following blog post, which is pretty clear: http://blogs.msdn.com/b/officeapps/archive/2012/10/24/using-an-odata-service-in-apps-for-sharepoint.aspx

  1. Using Visual Studio 2012, create a new project using the App for SharePoint 2013 template
  2. Add a Content Type for an External Data Source
  3. Specify the OData service URL
  4. Select the table you want to connect to
  5. Deploy and drink a Margarita

When doing so, Visual Studio connects just fine to the OData data source, and lets me select the table I want. However, when I deploy the app to my SharePoint Developer site and click on the list, I get the following error:

The remote server returned an error: (403) Forbidden.

Within my solution, the authentication mode is the default (PassThrough).

<Property Name="ODataServiceAuthenticationMode" Type="System.String">PassThrough</Property>

Why is SharePoint Online not passing my credentials on to the remote OData endpoint?

share|improve this question
    
I had a similar requirement, except I want to use a list within the same site collection as an Odata source for an External List and it does not work even for this. Which is a big shame as it would be very useful to share lists easily across sites. –  user16270 Apr 10 '13 at 15:30
    
I'm facing this issue right now.. any updates on this thread ? Thanks for helpping! –  Vinicius May 7 at 6:15

1 Answer 1

The answer seems to be that this does not work (or is blocked) across Site Collections on SharePoint Online. It works with no problems on the sample Northwind OData endpoint (http://services.odata.org/Northwind/Northwind.svc). I will move to my backup solution of using CSOM to download the data and then upload it to a different list.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.