Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have two identical InfoPath forms on two different site collections within the same web application (SP2010). One works fine but the other produces this error when submitting the form....

The form cannot be submitted. One or more field types are not installed properly. Go to the list settings page to delete these fields.

An entry has been added to the Windows event log of the server. Log ID:5567

I go to the list settings page but I have no idea which fields are not installed properly!

It opens in InfoPath and publishes without error.

I am a newbie to Sharepoint and the only references I can find when Googling talk about CAML queries and mismatching field names but I've no idea where to find CAML queries and fieldnames appear to be OK. I have played "spot the difference" with the working form and cannot find anything. All the fields are in a ContentType used by both forms.

The equivalent "edit" form works fine - again I can't see any significant difference with it.

Any clues would be most appreciated.

share|improve this question
    
Did you find a solution to this? I have the same exact issue. It's nutty. –  user15228 Feb 28 '13 at 18:54
    
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. –  Muhammad Raja Feb 28 '13 at 20:11
add comment

2 Answers

Go to list setting -> under columns -> delete invalid field.(i think it last column) after delete field, modify infopath form and publish again

share|improve this answer
    
I don't see any option for "delete invalid field". Under "Columns" on the List Settings page I have a table listing the columns with headings of "Column (click to edit)", "Type" and "Used in". Under this table are 3 options - "Create Column", "Add from existing site columns" and "Indexed Columns". –  Pandy Legend Dec 7 '12 at 13:18
add comment

Had similar problem. I deleted lookup fields and recreated that solved the problem for me. can you check by deleting lookup fields if u have any?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.