Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.
Add Solution - stsadm.exe -o addsolution -filename "C:\Users\Administrator\Desktop\Kingen.wsp" 

Deploy Solution-stsadm -o deploysolution -name Kingen.wsp  -url http//xxxx -local  -force -allowGacDeployment

Site Collection Administration > Site collection features > Active!

A Web Part or Web Form Control on this page Cannot be displayed or imported. The type is not registered as safe Need to add in Web.Config

System.IO.FileNotFoundException: The Web application at XX could not be found

How do i solve this i have used powershell to add and deploy my wsp but it says:

The Web application at http:/XXX could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application

how do i solve it, i am using my friends wsp package that has another url in my site and has another url

share|improve this question
    
i dont know if you put it in as an example or not but http:/XXX is not what you put in as the url for the webapplication is it? –  ali Sharepoint Dec 7 '12 at 11:42
add comment

1 Answer

The error is pretty straight forward, it can't find your web application. Go into Central Admin > System Settings > Configure alternate access mappings, and make sure the URL you're using is listed against the correct web application. It's not case sensitive, but it has to match exactly, http||https and and unique ports.

If you are entering it exactly correct, there's a bigger issue obviously. Check the ULS logs for additional info.

HTH

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.