Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

My task is the create a replication of a live site collection on a pre production server after the move none of the site collection Content type or site columns are listed.

So far I have copied the content database of the live site manually into the pre production sql server

I created a site collection by running this command

stsadm -o createsiteinnewdb -url http://domain/sites/collection -owneremail m.user@fake.com -ownerlogin fake\user_m -sitetemplate sts -title “Site Name” -databaseserver "SQLSERVER" -databasename “Intranet_TempDelete”

Then I deleted the database "Intranet_TempDelete"

And ran the command to attach the copied database

stsadm.exe -O addcontentdb -url http://domain/sites/collection -databasename WSS_Content_Collection

Is there a way to retreive these content type and columns?

share|improve this question
    
I opened sharepoint manager 2007 and can see the all content types listed, they must not be associated. –  chizzel Dec 6 '12 at 13:32
add comment

1 Answer 1

I tried to create a new site column and got this error

The directory is not a subdirectory of the root directory. (Exception from HRESULT: 0x80070090)

I searched around and it was suggested that an IISRESET helps resolve this error.

I ran "iisreset" and the content types and site columns are now populated.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.