Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a document library that I create via a feature. I have events on the library for when a document is updated, added and while the document is deleting.

When someone adds a document for the library I need to take the custom metadata that I've added and put in into a list on another site.

However, when I add the file through the UI, I don't see all the custom properties (metadata) in the dialogue box.

There is one exception, if I upload a .doc file then I see all the custom metadata fields, I've tried .bmp .docx .pdf and .doc.

The only time I see the custom fields are when i upload the .doc file. The same problem occurs when I try to edit the properties of that recently uploaded file, only the .doc item displays all the properties to edit.

WHY?

share|improve this question
    
If I create a document library through the UI, regardless of what document template I use when I upload any document I can see my custom fields. So I presume it has something to do with the way that I've created the document library in my feature but what options and settings did I miss? I basically created a new list item in my vs2012 project, with the type of "document library" and I changed nothing else... What have I missed? –  Linton Caldecott Dec 6 '12 at 6:50
    
Try changing the Content Type drop down menu from the popup and see if your content type exists. –  user3470 Dec 6 '12 at 7:01
    
Thanks, that helped! But now my irritation is my content type is set as default but sharepoint still defaults to "Document" when I upload anything other than the old 97-2003 ms office files. –  Linton Caldecott Dec 6 '12 at 7:35
    
How have you set it as default? Did you change the content type order of tthe list? –  user3470 Dec 6 '12 at 7:51
    
I have set it to default and made it the first item in the list. –  Linton Caldecott Dec 6 '12 at 8:21
add comment

1 Answer

Try changing the Content Type drop down menu from the popup and see if your content type exists. If it exists then maybe you need it to be selected by default when you upload a document.

To set it as default you need to change the content type order of the list. You can go to the library settings and in the content type section click on the Change new button order and default content type and set it to number 1. If you you want to do it programatically you can use this blog as a start.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.