Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a problem adding filters with parameters in the lists.

I added a query string parameter. It is used in a filter. When I select one item in the list, most ribbon buttons (edit and delete, specially) aren't enabled. If I remove the filter, the ribbon buttons are enabled again. I need those ribbon buttons to stay enabled.

I thought that it was necessary to update the ribbon buttons with RefreshCommandUI(), but it didn't work.

How can I enable those buttons again?

share|improve this question
1  
SharePoint version? –  Arsalan Adam Khatri Dec 5 '12 at 20:59
    
My version is SharePoint Foundation 2010, but it is the same in SharePoint Server 2010 –  Marlon Dec 5 '12 at 21:22
    
@Marlon: Can you explain more? where are you adding filters? which parameter or type of parameter? –  MAK May 16 '13 at 13:28
add comment

1 Answer

I actually found an answer to that problem.

Remove all querystring parameters. Then remove the corresponding filters.

Now, add another webpart: a querystring filter. Set it up to use the parameter you need.

Finally, connect both web parts (the querystring filter and the one displaying the list). Make it so that the querystring filter sends filter data do the list's filters.

Works like magic.

share|improve this answer
    
Filter web parts are not available in Sharepoint Foundation, which is what he was referring to in his comments. –  PirateEric May 15 '13 at 22:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.