Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I set up sharePoint 2013 web application I use this line of script

Add-DnsServerResourceRecordCName -HostNameAlias spdev.dev.com -Name portal -ZoneName dev.com
  • spdev - name of pc
  • dev.com - domain
  • portal - site adress

now I have 2 sites

  • CA - http:/spdev:8080
  • Team site - http:/portal

If I use IE all works fine, but in firefox I cannot log in to the team site. I see authentication form, I put correct credentials, then click log in button and see authentication form again.

How can I solve this issue?

share|improve this question
add comment

2 Answers 2

Here's what worked for me. I had made all of the usual disable loopback check setting changes in the registry, or so I thought.

I had HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0\BackConnectionHostNames set to include (one per line):

intranet.spdev.local
my.spdev.local

IE authentication to the host header-enabled sites worked, but Firefox kept prompting me for credentials over and over. Once I changed that setting to

intranet.spdev.local
my.spdev.local
intranet
my

Firefox authentication started working fine. So it appears that IE needs the fully qualified domain name, and Firefox likes just the host header name. For the disable loopback check settings instructions, look here.

share|improve this answer
add comment

Can you possibly enable NTLM authentication with Firefox core configuration. You can give this article a try.

It should work.

share|improve this answer
    
Yes, it doesn't work in my case ( –  Alexander Dec 3 '12 at 13:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.