Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm struggling to log in to SharePoint using FireFox. On entering the URL I get prompted with username and password, but when entering these the logon dialog keeps popping up and the page is not loaded.

The scenario is this: I have three web applications running. All of them have the same settings and runs on port 80.

Name                                    URL                     Port
intranetttest Currently Selected        http: //intranetttest/  80
MySite                                  http: //minside/        80
SharePoint - 80                         http: //sp/             80
SharePoint Central Administration v4    http: //sp:42424/       42424

In one out of three, I'm able to log in and browse the page. This one share the "base" URL with the central admin. The other two, I'm unable to log into using FireFox. IE and Opera works fine.

General settings, managed features, managed paths, service connections, auth providers, self-service site creations, user permissions, webpart security, user policy, anonymous policy and permission policy are all the same - as far as I can see.

I clearly seem to be missing something. Anyone had a similar problem?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Did you disable the dreaded "loopback check" ? http://support.microsoft.com/kb/896861

You can fire fiddler and launch FF afterward to check which ressource is triggering the credential (first request == IIS issue, a sub request = content issue).

share|improve this answer
    
I would try this too, however strange that it works on some browsers... –  Jussi Palo Dec 3 '12 at 12:17
    
Anything else than IE is less prone to automatically login user using NTML than itself (IE). –  Francois Verbeeck Dec 3 '12 at 12:24
add comment

An additional setting should be changed as well.

network.auth.force-generic-ntlm should be set to true.

network.auth.force-generic-ntlm | user set | boolean | true

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.