Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

My site is running under SharePoint 2010. Everything is Ok except when I change the locale of my site from Regional settings from US (English) to Malay. The my web part pages where user has number inputs, stops accepting decimals. User can enter the decimal but when Saving it saves the input without decimal e.g. 1.25 becomes 125 How to get around this problem? Or how can we have all locale compliant site.

Please help.

share|improve this question
    
might be worth checking the locale on the SQL server as well, I do recall a date issue whereby the SQL server has the wrong locale once –  pigeon Nov 30 '12 at 6:26
    
Well the UI changes the value before its sent to SQL. So whatever is displayed is saved in database. –  V.B Nov 30 '12 at 6:33
    
ok so you've change the locale of both the servers regional settings as well as the site / site collection regional settings to be the same and have performed at least one iisreset on the WFE? –  pigeon Nov 30 '12 at 7:07
    
No I have not changed the locale of my SQL server. There is another layer in between that is web service and no change in web service locale either. –  V.B Nov 30 '12 at 8:08
    
Have you find the solution for this? I am just curious... –  Norbert Dec 5 '12 at 11:41
add comment

1 Answer

I tried it out on my Sharepoint environment.

  • If I choose as the Regional Setting Malay (Brunei Darussalam), the accepted decimal separator is the "." (dot).
  • If I choose Malay (Malaysia), the accepted decimal separator is the "," (comma).

So I think you just have to choose the other Malay regional setting. No IIS reset was needed in my tests.

I hope it helped.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.