Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

It's only happening for one user where he keeps getting authentication pop up. After 4/5 attempts he can go to the document library page. Then when he clicks on a word file (where version and checkout is enabled) he gets endless pop up for credential.

No else having this trouble. I took following actions but problem still exists.

IE: Tools – Internet Options - Advanced tab – confirm Enable Integrated Windows Authentication is selected.

Not sure if i need to go through the steps in this link because about 2000 people are not seeing this but 1 employee. http://paulliebrand.com/2008/04/02/sharepoint-consistently-prompting-for-user-credentials/

share
    
Scenario 1 and 2 from that link are valid checks. Confirm those and let us know. –  David Lozzi Nov 29 '12 at 13:56
    
I remember this happens because the user is not correctly made in User Profile or UserInfomationList.. Solution was to delete the user from SharePoint, user profile, UserInformationList and then sync the user again with User Profile Service! This question was previously asked by someone, I just can't find it! –  Arsalan Adam Khatri Nov 29 '12 at 14:35
    
@ArsalanAdamKhatri: That particular users in so many sites so I can't just delete him from all the sites and re add them. Can you think of any other solution? –  Maria Burton Nov 29 '12 at 14:50
    
@DavidLozzi: I will try the link and go through some of the items. Some of the internet explorer settings are admin driven and are pushed through GPO. I can't even see all the trusted sites in the intranet zone as the list is grayed out and it's longer (meaning scroll down is disabled too). –  Maria Burton Nov 29 '12 at 14:52
    
try opening IE with no add ons, should be an option in the All Programs list. Also, I'm assuming this is IE8/9? –  David Lozzi Nov 29 '12 at 14:58

2 Answers 2

Try and run the Office Diagnostic Tools first, if this doesn't work then run fiddlr2 on the client box to see what requests are being made when the document is opened. You should be able to see whats requests and response are being made. This might give you a clue...

enter image description here

share
    
I dont have that type of luxury when I am with the user. He is already irate. I had him log off and i logged in to his pc and my profile works as expected. Something tells me is not sharepoint or IE or local. It's his profile. I am clueless as to what else. –  Maria Burton Nov 29 '12 at 18:09
    
I'm glad it worked out for you, fiddler saved me so many times. –  chizzel Dec 6 '12 at 12:46
up vote 5 down vote accepted

Per Chizzel, I installed fiddler and found 401 error for "/_vti_bin/_vti_aut/author.dll". after googling I found this article "http://blogs.microsoft.co.il/blogs/choroshin/archive/2012/11/06/sharepoint-getting-authentication-login-prompt-when-trying-to-open-office-document-with-unique-permissions.aspx" which talked about disabling "lockdown" feature. walla, everything started working like I expected.

share

This site is currently not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .