Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

After a recent master page update I am noticing that some pages which usually have embedded forms are now displaying the following super informative error:

There has been an error while loading the form. A required resource could not be downloaded. To try to resume the download, refresh the page.

I have cleared all browsing history; this error occurs in all major browsers, for all users. I have tried opening the forms in question in Infopath and republishing them, I have tried rebuilding the pages containing the forms in question. Nothing helps.

This error is mentioned a fair bit online, but there are rarely any answers or advice. Is there any way I can at least get some decent error reporting from my server? We do most of our work through the front end, but I could harass our service provider if I had the vaguest idea what to ask for.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

For error reporting I would check the logs on the server. (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS) There are some good software for reading the logs, like ULSViewer.

share|improve this answer
    
Thanks, I'll ask our server guys if they can provide us with the contents of the path. –  Sinetheta Nov 29 '12 at 18:55

I received a similar error message. See solution here, http://riedoh.blogspot.com/2014/05/there-has-been-error-while-loading-form.html

As a solution / workaround I had to configure IIS,

  • Change the application pool identity to an Admin User
  • Update the Basic setting of the site to use "Application user (pass-through authentication)" as the Path Credentials
share|improve this answer
    
Please provide a brief explanation of the solution in your answer. Giving the URL to your blog post is great, but some day that link may break. If that happens, your answer here will be rendered useless. Thanks! –  Phil Greer May 26 at 20:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.