SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have developed a portal couple of months back using SharePoint 2010. My images are in "Style Library/Images" folder. It was working fine and whatever images ive places from that image library on pages were appearing fine too and in that time ive replaced and added many images without any problem.

Today a user requested to update the ORG chart so ive uploaded a updated image in "Style Library/Images" folder..checked in..but when i went to the page there was "X" mark there...being a site collection admin i can see the pic but users have "X"..

Also when user copy pasted the link directly in browser like this. they get "ACCESS DENIED"

what is the problem now with images folder?

share|improve this question
I have a similar problem with the corev4.css file; new user is getting access denied to this file. Where would you grant access to "Style Library/Images" or the '-Styles' folder in my case. I don't see any option in neither SP Designer nor SP. I don't have server access. Thanks, Laura – user3891775 Sep 19 '14 at 13:47
up vote 0 down vote accepted

It can happen only if users do not have access to "Style Library/Images" folder, check permission for the folder "Style Library/Images" if users(target group) do not have "View"/Read permission then grant View permission, your issue should be resolved

share|improve this answer

Check publishing Feature if it activated means then check out and check in the current page.

or else check user having read permissions to Images Folder.

share|improve this answer

I have this "Restricted Reader" group ..ive checked the permission and "Authenticated Users" group was missing..added back and it worked :) ..don't know who removed it..neway thanks for the help.

share|improve this answer

add Type="GhostableInLibrary" property in <File Path=".." Url=".." />

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.