Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I develop SharePoint 2010 web application in Windows 7 + SharePoint 2010 Server machine. I have used Visual Studio 2010 for the development. In my application I have three different projects each for Site Definition, List Definitions and Visual Web parts respectively. Now I need to deploy my application in a different server machine with Windows Server 2008 with VM containing SharePoint Server 2010. Please someone help me with steps in deployment?

share|improve this question
    
You should work on your accept rate to get more feedback. –  Francois Verbeeck Nov 23 '12 at 8:19
add comment

1 Answer 1

up vote 0 down vote accepted

Your VS projects will generate SharePoint packages (WSP) when you package them (right click on the project and package).

On your target environment, you'll need to create a web application then install & deploy the WSP for your site definition (that will be a farm solution). Once done, you'll be able to create a site collection of that template and afterward you'll have to install & deploy the last two WSPs and activate the relevant features to have your list definition & webparts available.

share|improve this answer
    
Thank you for the guidance. I have deployed the my three wsp files and activated the features. wsp1-contains masterpage, custom css and the custom js files. wsp2-contains list definitions. wsp3-contains webparts. wsp1 and wsp2 were globally deployed and wsp3 was deployed to a web application. Now in the web application I can find all the webparts but not any lists and styles. –  Suja Shyam Nov 23 '12 at 8:59
    
Are you sure the associated feature is activated on the target environment ? –  Francois Verbeeck Nov 23 '12 at 12:55
    
yes am sure about it. In wsp1 and wsp2 the scope of the feature is web and wsp3 the scope is site. –  Suja Shyam Nov 26 '12 at 4:08
    
Thank you for the supports. I resolved the issue by changing the scope of the globally deployed wsp to "Site" from "Web" and re-deploying the wsps to the web application. –  Suja Shyam Nov 26 '12 at 7:46
    
glad to read it's solved. Good luck for the other tasks :) –  Francois Verbeeck Nov 26 '12 at 20:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.