Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

In "Central Administration – System Settings – Manage Farm Solutions" I can see that my Solution has been deployed, to http://sp2010/. However when I go to there, and try to activate this feature through "Site Settings - Manage Site Features" or "Site Settings - Site Collection Features" I can't find it, it's not there in the list!

Here's the feature.xml:

<?xml version="1.0" encoding="utf-8"?>  
<Feature  Id="118849a2-9e81-4046-9329-36ebfdff5b8b"
          Title="edu.yale.som.auth.admin"
          Description="Deployment for edu.yale.som.auth.admin"
          Version="14.0.0.0"
          Hidden="FALSE"
          Scope="Web"
          DefaultResourceFile="core"
          ReceiverAssembly="edu.yale.som.auth.admin, Version=1.0.0.0, Culture=neutral, PublicKeyToken=3b821d30408baea0"
          ReceiverClass="edu.yale.som.auth.admin.Deploy"
          xmlns="http://schemas.microsoft.com/sharepoint/">
  <ElementManifests>
    <ElementManifest Location="elements.xml"/>
    <ElementFile Location="FBAProcessSingleUser.webpart" />
    <ElementFile Location="FBAProcessAllUsers.webpart" />    
  </ElementManifests>
</Feature>

I've downloaded this project from http://eduyalesomauth.codeplex.com/

Any ideas how I can activate this feature?

share|improve this question
add comment

2 Answers 2

You can use the STSADM.exe or powershell commands to activate the same.

for stsadm

stsadm -o activatefeature -name FeatureFolderName -url http://yourweb

for powerswhell Enable-SPFeature FeatureFolderName -Url http://yourweb

share|improve this answer
    
thanks, however it didn't work for stsadm. Here's the error: "Feature with Id '###' is not installed in this farm, and cannot be added to this scope." I tried -o installFeature but that throws an Exception from Deploy.cs –  Anonymous Sep 2 '10 at 8:33
    
Can you tell me the exact exception you get while executing this: stsadm -o installfeature -name FeatureFolderName –  Vivek Sep 2 '10 at 11:29
add comment
up vote 0 down vote accepted

My WSP was not complete, when I opened it with winRAR I couldn't verify feature.xml and other necessary files. Apparently I had the wrong WSPBuilder installed. The package now shows up in the Site Collection Features-screen.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.