Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to place a WSRP (Web Services Remote Portlet) to a PeopleSoft producer and am having some issues once connected. Please bear with me as I know nothing about how Peoplsoft works or this web part. I followed the instructions on http://www.eblogin.com/eblogin/post/2012/01/19/sp-WSRPconfig.aspx to setup the web part config and saved in the correct spot.

When adding the web part can see the config title that I created so I know SharePoint is seeing my config. I am able to connect to the PeopleSoft portlet. I know this is the case because I was unable to do so before due to an error in the config. Once corrected the connection to portlet seemed to be achieved.

Once the connection is made the Web Part is displaying the following error message: "The portlet server returned an error. It may not be configured correctly. The details of the error message have been added to the SharePoint log file on the SharePoint server. Please contact your SharePoint administrator to correct this problem."

In the logs there are two errors:

1) Runtime Error in method WSRPMarkupProxy.DoGetMarkup of type System.Web.Services.Protocols.SoapException. The exception was System.Web.Services.Protocols.SoapException: java.lang.NullPointerException
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.SharePoint.Portal.WebControls.WSRPWebService.WSRP_v1_Markup_Binding_SOAP.getMarkup(getMarkup getMarkup1)
at Microsoft.SharePoint.Portal.WebControls.WSRPMarkupProxy.DoGetMarkUp(Dictionary`2 parameters)

2) Runtime Error in method WSRPMarkupProxy.RenderPortlet of type System.Web.Services.Protocols.SoapException. The exception was System.Web.Services.Protocols.SoapException: java.lang.NullPointerException
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.SharePoint.Portal.WebControls.WSRPWebService.WSRP_v1_Markup_Binding_SOAP.getMarkup(getMarkup getMarkup1)
at Microsoft.SharePoint.Portal.WebControls.WSRPMarkupProxy.DoGetMarkUp(Dictionary`2 parameters)
at Microsoft.SharePoint.Portal.WebControls.WSRPMarkupProxy.RenderPortlet(HtmlTextWriter writer)

I can't find anything on these errors anywhere in Google. I was wondering if someone might perhaps have seen this before and\or knows the resolution to the issue.

Thank you in advance

share|improve this question
    
You may want to contact PeopleSoft for support on this. The web part is unable to connect to a web service. –  RJ Cuthbertson Nov 19 '12 at 20:23
    
Thanks for the reply. We ended up going with a different solution entirely. It would be nice if there was more documentation out there for this web part. –  HawkeyeD Nov 21 '12 at 13:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.