Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to share a portal site with a few clients and allow them to use their own email address. (via office 365 plan E3 if that matters)

I went to the admin center -> site collections -> settings -> Manage external users

I selected Allow and clicked save.

Now in the client portal, site actions -> share site, it still says:

Invitations to users outside your organization are currently disabled.

Any idea what I'm missing?

Thanks in advance

share|improve this question
1  
Which plan are you on? –  Hugh Wood Nov 19 '12 at 15:14
    
E3 (short comment bad) –  sharoz Nov 19 '12 at 15:18
    
can you share documents with external users in sharepoint 2013 on-premise? –  user20337 Oct 23 '13 at 17:07

2 Answers 2

Sorry when I asked that question I forgot that they updated the PALs earlier this year, my bad.

Plan P : 500 (Fixed)

Plan E : 10,000 (Business desk escalation)

Dedicated: 10,000 (Purchasable PAL Packs)

PALs are reusable if you delete the account in which is using up the PAL, so administration is key to small businesses.


Go to your SharePoint Online administration panel http://sitename-admin.sharepoint.com

Click "Manage Site Collections"

Click "Settings" on the Ribbon and then "Manage External Users"

Select "Allow" on the radio button on the popup.

Done.

You have 50 licences with your plan as basic, then extra as you move up plans + you can buy more.

share|improve this answer
up vote 0 down vote accepted

A colleague figured it out.

What was missing was the per-site setting.

At the site, go to Site Actions -> Site Settings -> Site Collection Administration -> Site collection features -> External user invitations -> Activate

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.