Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Users on my 2010 site can't edit a document attached to a discussion board post even though they have "Contribute" access. Users with "Full Control" can, of course, but users with Contribute cannot.

This seem to be an issue with the discussion board web part itself, because those users with "Contribute" access can edit documents in a Document Library.

How can I set up the Discussion Board to enable "Contribute"-level users the permission to edit documents?

Thanks!

share|improve this question
    
I think I am having a similar problem to you however mine is on a Sharepoint 2013 setup. Do you have any idea how to give contributors in my discussion board access to upload documents and attach pictures to their posts? –  Wosih. May 14 '13 at 14:39
add comment

1 Answer

Go to the Discussion Board settings and go into the Advanced settings. Change the Item-Level permissions for Create and Edit access to Create and Edit all items.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.