Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have SP Foundation site which is running Search Server Express.

When the site collection, IIS, and SSE are configured for a FQDN rather than the default machine name, the crawling service completes, but does not crawl past the root, and thus returns no search results.

I have added a document library with text files. When the site is configured only for the machine name, e.g. the sharepoint default (http://mymachine_name) the search crawls correctly and finds all of the files.

What am I missing with the configuration? Is the process similar for configuring SSL?

Here is the current configuration:

IIS:

IIS Bindings

AAM:Alternate Access Mappings

SSE Full Crawl Results: SSE Full Crawl Results

share|improve this question

1 Answer 1

up vote 0 down vote accepted

After some more extensive work in looking into this issue I was able to resolve this problem. If you are having similar problems, ensure the following:

  1. Ensure that the GUID for the pdf key does not have any trailing white-space when you copy it! This is very easy to miss:

"HKLM:\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\14.0\Search\Setup\ContentIndexCommon\Filters\Extension.pdf"

"{E8978DA6-047F-4E3D-9C78-CDBE46041603}"

  1. If you have SSL setup with an un-signed certificate, turn off SSL warnings for Search Server Express
  2. Make sure you have configured your "Server Name Mapping":

Address for indexing: 'http://portal.contoso.com'

Address for display in search results: 'http://machineName'

  1. Make sure that the PDF file type is added in Search Server Express
  2. In certain configurations, you may need to disable LoopBackCheck and also disable StrictNameChecking (understand the implications of these changes first! Check the microsoft KBs):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.