Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a document library that has been used for the last year, but as of today users are unable to access the library. When they try to access it, they get the error "An unpexected error has occurred". This happens to all users included Farm Admins.

I have requested the logs to see if I can see any funnies, but that takes time.

no changes have been made to this library for the last 6 or 7 months, nor have any patches been applied for the last two months.

Has anyone experienced this before?

NB: This is on SharePoint 2007.

I have applied the suggested logging Hugh below, it provided nothing extra only the same error message on the page, and nothing extra in the EventLog or SharePoint logs. This has now escalated and users are unable to use this sub site, which means a whole business unit is now unable to work.

Any additional ideas on this would be helpful!

share|improve this question
    
This error really doesn't give anything. You will need to turn errors to be shown fully with your web.config 'SafeMode MaxControls="200" CallStack="false"' to 'SafeMode MaxControls="200" CallStack="true"' and <customErrors mode="On"/> to <customErrors mode="Off"/> to get more information. –  Hugh Wood Nov 14 '12 at 14:35
    
Thanks Hugh, I did apply these changes to the web.config for the Web App but it provided no new information. Any other ideas? –  MrThirsty Dec 24 '12 at 12:09
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.