SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In extension to this question of mine, If I put location of custom action as


it gives me error

Failed to create a control from assembly '', class '': The control with assembly name '', ' class name '' is not allowed for web at URL ''. The type is not registered as safe.

however it works for most I tried in here



<?xml version="1.0" encoding="utf-8" ?>
<Elements xmlns="">
  ControlAssembly="abc3333.myworkspacename, Version=, Culture=neutral, PublicKeyToken=d702315f0f3475cf"

      Title="My Custom Action 2"
      ControlAssembly="abc3333.myworkspacename, Version=, Culture=neutral,                        PublicKeyToken=d702315f0f3475cf"


Now If I remove ControlAssembly or ControlClass from CustomActions then it stops giving me error and shows my new action in action menu but then I won't be able to do any action, now if I change location and groupId and keep assembly in it then it does work as well.

So I guess GroupID "ActionsMenu" doesn't take control assembly as safe control or something, I think I am missing some concept.

share|improve this question
what Custom Action Group ID did you put in? – ali Sharepoint Nov 12 '12 at 14:41
up vote 0 down vote accepted

My User control class wasn't declared as public, so WSP Builder wasn't adding it as a safe control to web.config neither in Manifest.xml.

Many thanks to comments in this Article by Terry R Not sure who that is personally but solved my issue :).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.