Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

In my document library the ribbon tabs (Documents and Library) is not visible unless I click any document. Earlier all the tabs were visible as soon as I navigate to the document library. Why this is happening... Even one of our client is complaining about such behavior.

enter image description here

Thanks.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Have you added another Webpart to the AllItems Section? I get this behavior as soon as I add any Webpart to a View.

Removing all other webparts except for the List View Webpart itself should bring you back the desired behavior.

UPDATE

This answer describes a way to get things actually working. Putting the mentioned code inside a

$(function() {...})

worked like a charm here.

share|improve this answer
2  
Yep, if you have another webpart on the page it will break the default behaviour, so basically when you open the page the ribbon will be empty at all. Only when you select a web part the focus will be made on it, it will activate the correct contextual tabs. –  Shkipper Nov 9 '12 at 8:18
    
I guess if you have a deep look into the behavior of the mouse-click, maybe you could simulate such a mouse-click with a jQuery snippet, which you would include in a non-visible form-webpart. –  curmudgeon Nov 9 '12 at 8:23
    
Thank you very much "Curmudgeon" and "Shkipper" for your's valuable inputs. That really helped me to resolve my problems. Yes there was a hidden CEWP on the page that was making the tabs hide. –  Zakir HC Nov 19 '12 at 8:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.