Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have ratings enabled on multiple libraries. I have the user profile and user profile synchronization service applications/services configured and running. I have the user profile activity feed job, social data maintenance job, and social data synchronization jobs running every 1 minute.

A user will rate an item and receive the success message that it will be processed. The rating however is never saved. Once user leaves page and comes back (minutes, hours, days later) their rating is not there and the number of ratings column never displays a number.

Any guidance would be greatly appreciated!

share|improve this question
    
If both services are running every minute AND the feature is enabled properly (enable-spfeature -identity 915c240e-a6cc-49b8-8b2c-0bff8b553ed3 -url server), check the ULS for errors and windows logs for errors before continuing. If after that there is nothing visibly wrong then restart the services and reenable the feature and try again, being services check ULS and Windows Logs. –  Hugh Wood Nov 8 '12 at 8:44
add comment

1 Answer 1

http://sharepoint.stackexchange.com/a/51650/7904

Try this ^

Basically, the user profile service permissions has a 'Use Social Features' checkbox, in my case it was unticked.

share|improve this answer
    
Go to User Profile Service Application in Central Administration. Click Manage User Permissions and check if all authenticated users has rights to Social Features. –  Maria Burton Apr 2 '13 at 18:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.