Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to get SharePoint's email features to work with Google Apps (alerts, emails generated by workflows, etc).

Google Apps uses port 587 for smtp and I know that the default smtp port cannot be changed in SharePoint, so I have attempted to set up a new smtp virtual server as an smtp relay. In this, I've enabled TLS, and set the default TCP port to 587.

Under Central Admin -> Operations -> Outgoing Email Settings I already set up the correct configuration - I think:

To test this I'm using a program created by Rodney Viana. This reports "Email has been sent successfully via SharePoint", but I don't receive it.

  • Outbound SMTP server - IP address of my smtp server
  • From Address - administrator@foo.com
  • Reply-to Address - blank
  • Character Set - 65001 (Unicode UTF-8)

Any ideas?

share|improve this question

2 Answers 2

I tested and you are right with the TLS issue.

HOWEVER enter codeplex proxy solution

Does what it says "SMTP Proxy for GMail and Windows Live Mail/Hotmail"

Worked perfectly for my email alerts on my test server, while testing it.

share|improve this answer
    
Looks nice. I'll try it. –  Black Knight Nov 22 '12 at 14:06
    
I just CANNOT get this to work. I get "No connection could be made because the target machine actively refused it 192.168.1.91:25" where 192.168.1.91 is my sharepoint server and where SMTPProxy is running. –  Black Knight Jan 27 '13 at 20:41

This seems kinda "dirty" but it works.

http://www.delphi-ts.com/blogs/lozzi/post/2011/02/09/Sending-SharePoint-emails-through-alternate-ports.aspx

Basically setting up a proxy for sending mail, pointing SharePoint to the proxy (standard port), and allowing the proxy to relay to the correct destination port.

share|improve this answer
    
Yeah when I read this I was thinking a smtp proxy, it's the only real way. –  Hugh Wood Nov 16 '12 at 11:21
    
This is the setup I have already tried (except that my SMTP server is running on a separate physical server). This may or may not be the problem, I can't tell. I will try installing an smtp server on the sharepoint server. –  Black Knight Nov 16 '12 at 21:26
    
I also notice that the blogger in your linked article failed to get TLS working. Ideally I would like TLS to be enabled. Thanks for the link anyway - I'll try following it step by step. –  Black Knight Nov 16 '12 at 21:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.