Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

The title of this question comes from the logs of SharePoint 2010. I defined a three-state workflow and the workflow gives errors when trying to send e-mail to the users participating in the workflow. I can't see anywhere 'someone@example.com' is defined. The only configuration was Search Service app configuration and I changed the mail address to a valid one.

share|improve this question

2 Answers 2

I had the same problem. In my scenario the error was caused because my sharepoint server was not authorized to send mails in my mail server.

share|improve this answer
    
Do you have any more information about the steps you took to fix this? –  Kit Menke Feb 7 '12 at 19:34
    
I'm using a relay mail server on a linux machine. It has an ACL per machine, so if the machine is not authorized the connection is rejected. In my scenario I just needed to add the sharepoint server to the mail relay ACL. I wrote it here because I thought it was interesting the few information received from the error message. I hope it helps –  Inventa00 Feb 7 '12 at 23:28

Might this address be set in your outgoing email settings in Central Admin?

share|improve this answer
    
No changed it to sharepoint@domain.local. I only get this error when SharePoint tries to send an e-mail to the admin user. Suspect that something is wrong with User Profile Sync. –  Élodie Petit Aug 29 '10 at 11:32
    
You can always edit the user's profile, you do not have to rely on synchronization to get details into the profile. –  Mike Oryszak Aug 29 '10 at 12:52
    
I edit the profile but it doesn't get synchronized with the normal sites unless I run the synchronization job. The weird thing is, I can see that the mail address is set to sharepoint@domain.local but after synchronization it is set back to someone@example.com. How can I get rid of this someone thing? –  Élodie Petit Aug 29 '10 at 12:59
    
Ok, can please someone explain this thing to me? Central Administration Manage User Profile plage shows the mail address as sharepoint@domain.local. My Profile page at the default web application shows the e-mail field "empty". My Settings page shows the mail address as "someone@example.com". This thing will make me go mad! –  Élodie Petit Aug 29 '10 at 13:08
1  
You're suffering from User Profile Hell, a common problem in SharePoint 2010. First things first, i'd recommend checking your email address in Active Directory to check to make sure that field is set properly - if it's reverting itself to the wrong thing, it must be getting that information from somewhere. After you have done that, provided this isn't a production environment, i'd recommend rebuilding your user profile store and user profile sync service. Also, if you haven't yet upgraded to Service Pack 1, i'd recommend giving that a shot. –  Mike Redden Aug 11 '11 at 0:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.