Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have not configured Enterprise serarch but normal search. When I go to My Site at the top of the page there is a textbox which contain "Search fo persons". When I enter a username and press enter no result found.

Do I need to have profile Synchronization?

When I go to "User Profile Service Application" at the right side of the page it says "Number of profiles 21" and when I go to Content Source of Search Service Application I can find sps3://dev So does it means that the users has been crawled? What must I need to do to make search find the users? Thank you.

share|improve this question
add comment

1 Answer

It sounds like you are pretty much all the way there. A couple things I would make sure:

  • Are you missing any key alternate access mapping entries? Sometimes mismatched alternate access mappings can cause problems with search though I don't know if this would be your exact problem

  • Have you run a full crawl since the user profile import? This is what I'm leaning towards most. I believe that new users found during the user profile sync will not show up unless you do a full crawl. Incremental would not be sufficient. For this reason you may want to split your users into a separate content source so that you can continue to do incremental crawls on your data, and full crawls on people.

share|improve this answer
    
thanks, I am on my development environment and trying to make search people work. when I go to AAM I can see all web applications. my question is do I need make a user sychronization? how do you make a profile import? Yes I have run full crawl. –  Medes Nov 7 '12 at 15:58
    
"When I go to "User Profile Service Application" at the right side of the page it says "Number of profiles 21" is what you said in your post which means you have run a user profile import at least once. Are you expecting more than 21 profiles? –  ToddersLegrande Nov 7 '12 at 16:15
    
No I am not expectiong more than 21 users. I meant do I need to run it again. why when I search for my user "test1" it finds only documents and lists which test1 is been active (as owner of a document or komment which contains test1)?? –  Medes Nov 8 '12 at 7:45
    
Ok, you shouldn't have to do another profile sync then. Are you on http or https? If https your search crawl entry should be sps3s instead of sps3. –  ToddersLegrande Nov 8 '12 at 12:44
    
Also, are there any errors in your crawl log regarding the sps3 content source? –  ToddersLegrande Nov 8 '12 at 12:46
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.